System requirements

Web

Songspace officially supports the following web browsers running Windows, Mac OSX, or Linux. Your browser version must be a stable release and not an alpha, beta, or pre-release version.

Browser Versions

  • Google Chrome: Latest two versions (Chrome 59 & 60)
  • Firefox: Latest two versions (Firefox 52 & 53)
  • Safari: Latest two versions (Safari 9 & 10)
  • Microsoft Internet Explorer: Latest version only (IE 11)
    Note: Microsoft Edge is not officially supported yet

Browser Configuration

  • JavaScript must be enabled
  • Cookies must be enabled
  • localStorage must be enabled
  • Adobe Flash Player must be installed for Safari 9 users.

Mobile

  • iOS: iOS 8 and higher are supported
  • Android: Android 4.0 and higher

Note: the majority of the Songspace web application is not viewable on mobile browsers. It is recommended that you install the iOS or Android application if you wish to login and manage your account from your mobile device.

Have more questions? Submit a request